Windows Server 2012 R2 support

Apr 25, 2014 at 2:21 PM
Does your module support WSUS on Windows Server 2012 R2?
Coordinator
Apr 29, 2014 at 1:45 AM
This version should support WSUS 6.3 on Server 2012 R2. If you are running this on the server, you will have to import the UpdateServices module (ipmo UpdateServices) to load the assembly.
May 16, 2014 at 3:07 PM
I just started a migration from our older wsus server to the default wsus (i imangine v6.3) on 2012 R2 Update 1.
i've run the command ipmo UpdateServices and ipmo PoshWSUS and then try to connect to the 2012 R2 WSUS and it gives me;
Warning: Unable to connect to [WSUSServer].

I can connect to our older wsus server (wsus 3.??).

Can someone confirm if this is working with 2012 R2 and what they did to get it going?

thanks
Aug 22, 2014 at 10:10 AM
Hi

I am having the same problem.

Does PoshWSUS work with WSUS 6?

I have the UpdateServices module loaded as suggested then loadPoshWSUS but get the same error: unable to connect, but I can connect to the old wsus server even on the new (2012R2) wsus server console

Thanks
Aug 22, 2014 at 10:36 AM
Edited Aug 24, 2014 at 8:51 AM
Found the solution!!

Started using Powershell ISE and it sh0ws all the parameters for a command easily.

Simply add -port 8530 and it connects to the server.

i.e.

connect-poshwsusserver -wsusserver <server-name> -port 8530

Cheers
Aug 24, 2014 at 7:43 AM
The question is about the following: Microsoft do not officially support WSUS 6.3 management via 3.x management console (although, it is technically working). So it would be nice to hear that module author is aware about this and tested the module with WSUS 6.3.
Sep 4, 2014 at 5:52 PM
Thanks Zpitzy!

I only realised yesterday that WSUS 6 (ie 2012 & 2012R2) use port 8530 / 8531 (ssl)
So zpitzy solution is working to allow the powershell commands to work with WSUS 6.x

I also agree with Camelot that poshwsus should be tested against WSUS 6.x to confirm compatibility.

My script is working well now.
thanks